Service Degradation - MTC Namibia
Incident Report for SMSPortal
Resolved
This incident has been resolved and all pending messages have been processed by MTC Namibia.
Posted Jul 28, 2021 - 20:56 CAT
Investigating
We are currently experiencing a connectivity issue with MTC Namibia and as a result SMS delivery towards MTC Namibia is degraded. The operator is working to resolve the issue as quickly as possible. Please do not resubmit any messages.

Type: Network Outage
Impact: Customers may experience irregular delivery with inconsistent delivery times when sending to MTC Namibia.

We appreciate your patience while the operator works to resolve the issue and we will keep you updated.

Please contact support@smsportal.com should you require further information or assistance.

The SMSPortal Team
Posted Jul 28, 2021 - 17:48 CAT
This incident affected: Region (Africa).