Cell C South Africa Delivery Issue
Incident Report for SMSPortal
Resolved
After extensive monitoring, we believe that the issue has been fully resolved.
Posted 3 months ago. Jul 08, 2017 - 15:21 CAT
Monitoring
Cell C has identified and fixed the issue. All failed messages have been resubmitted at no additional cost to our customers. We will continue to monitor.
Posted 3 months ago. Jul 08, 2017 - 08:55 CAT
Investigating
Cell C is currently experiencing a technical issue on their platform. A high percentage of Outbound (MT) messages are failing with status UNDELIV. Cell C is working on a solution and we will keep you updated.
Posted 3 months ago. Jul 08, 2017 - 07:29 CAT