Cell C Message Delays
Incident Report for SMSPortal
Resolved
Cell C has resolved the issue, and services have been restored.
Posted 3 months ago. Jul 04, 2017 - 09:46 CAT
Monitoring
Cell C has partially restored connectivity and messages are now processing normally. We will continue to monitor.
Posted 3 months ago. Jul 03, 2017 - 17:43 CAT
Identified
The cause of the general outage is due to a link that has failed. Their technicians are working on a solution but do not have an estimated resolution time.

A portion of Outbound (MT) and Inbound (MO) messages will be delayed to and from Cell C.
Posted 3 months ago. Jul 03, 2017 - 16:59 CAT
Investigating
Cell C is currently investigating a technical issue that may delay the delivery of certain messages. We will continue to give regular feedback and apologise for any inconvenience caused.
Posted 3 months ago. Jul 03, 2017 - 16:22 CAT