Service Degradation: MTN SA DLR Delays
Incident Report for SMSPortal
Resolved
MTN SA have identified and resolved the issue.
Posted 21 days ago. Apr 02, 2019 - 12:50 CAT
Investigating
MTN SA are investigating an issue causing a portion of Delivery Statuses (DLRs) to be delayed.
Posted 21 days ago. Apr 02, 2019 - 10:48 CAT
This incident affected: Region (Africa).