Service Degradation - MTN SA

Incident Report for SMSPortal

Resolved

We believe the issue to be resolved as we are no longer observing any message rejections and the errors stopped at 16:31 (UTC+2). We are still awaiting feedback from MTN SA and will continue to monitor extensively. This incident will be updated should the situation change.
Posted Aug 17, 2026 - 17:49 CAT

Investigating

MTN South Africa is currently rejecting a small portion of outbound messages. As a result, customers may receive an "UNDELIV" delivery status for some messages sent to MTN subscribers. MTN is aware of the issue and their technical team is actively investigating.

Type: Network Degradation (MTN)
Issue Start Time: 17 Aug 2026 @ 13:12 (UTC+2)
Impact: Customers may receive an incorrect "UNDELIV" delivery status for a portion of outbound messages to MTN SA subscribers.

We appreciate your patience while the operator investigates the issue and will provide further updates as more information becomes available.

Please contact help@smsportal.com should you require further assistance.

The SMSPortal Team
Posted Aug 17, 2026 - 15:31 CAT
This incident affected: Region (Africa).