Service Degradation - Cell C SA
Incident Report for SMSPortal
Resolved
Cell C SA informed us that the issue has been resolved.
Posted Feb 22, 2023 - 17:48 CAT
Investigating
Cell C SA performed overnight maintenance on their platform, resulting in an ongoing technical outage.
As a result, customers may experience irregular delivery with inconsistent delivery receipts when sending towards Cell C SA.
The operator is working to resolve the issue.

SMSPortal has rerouted all possible traffic in order to limit any impact to customers.

Type: Delivery Degradation
Impact: Customers may experience irregular delivery with inconsistent delivery receipts when sending towards Cell C SA.

We appreciate your patience while the operator works to resolve the issue and we will keep you updated.

Please contact support@smsportal.com should you require further information or assistance.

The SMSPortal Team
Posted Feb 22, 2023 - 16:38 CAT