Service Degradation - MTC Namibia

Incident Report for SMSPortal

Resolved

After extensive monitoring we believe this issue to be resolved.
Posted Mar 12, 2025 - 16:32 CAT

Monitoring

MTC Namibia have informed us that the issue has been resolved. We will continue to monitor extensively.
Posted Mar 12, 2025 - 11:52 CAT

Investigating

We have been informed that MTC Namibia is experiencing network issues. Their team is actively working to restore services as soon as possible. SMSPortal is currently queueing all messages until the issue is resolved. Please do not resubmit any messages as they will be processed once connectivity is restored.

Type: Network Outage
Issue Start Time: 12 March 2025 @ 09:00 (UTC+2)
Impact: Customers may experience irregular delivery with inconsistent delivery times when sending to MTC Namibia.

We appreciate your patience while the operator works to resolve the issue and we will keep you updated.

Please contact help@smsportal.com should you require further information or assistance.

The SMSPortal Team
Posted Mar 12, 2025 - 10:35 CAT
This incident affected: Region (Africa).