Service Degradation: MTN SA DLR Delays
Incident Report for SMSPortal
Resolved
MTN SA have resolved the issue.
Posted 5 days ago. Dec 05, 2018 - 23:09 CAT
Investigating
We are currently experiencing a delay in delivery receipts for a portion of MTN SA messages. MTN is investigating and hope to have this resolved as soon as possible.
Posted 5 days ago. Dec 05, 2018 - 21:33 CAT
This incident affected: Region (Africa).