Service Degradation - MTN Eswatini
Incident Report for SMSPortal
Resolved
Services have been restored and MTN Eswatini have confirmed that the issue has been resolved.
Posted Jul 23, 2024 - 16:38 CAT
Investigating
MTN Eswatini is currently experiencing technical issues on their network. SMSPortal are queueing all messages while we wait for the issue to be resolved. Please do not resubmit any messages.

Type: Network Outage
Impact: Customers may experience irregular delivery with inconsistent delivery times when sending to MTN Eswatini.

We appreciate your patience while the operator works to resolve the issue and we will keep you updated.

Please contact support@smsportal.com should you require further information or assistance.

The SMSPortal Team
Posted Jul 23, 2024 - 13:35 CAT
This incident affected: Region (Africa).