Service Degradation - MTN SA
Incident Report for SMSPortal
Resolved
After extensive monitoring, we believe this issue to be resolved.
Posted Jul 02, 2024 - 17:24 CAT
Investigating
We are currently observing delays with delivery of messages towards MTN SA.

Type: Mobile Network Outage
Impact: Customers may experience irregular delivery with inconsistent delivery times when sending to MTN SA.

We appreciate your patience while the operator works to resolve the issue and we will keep you updated. Please do not resubmit any messages.

Please contact help@smsportal.com should you require further information or assistance.
Posted Jul 02, 2024 - 14:52 CAT
This incident affected: Region (Africa).